CRAN Package Check Results for Package emmeans

Last updated on 2024-06-13 05:59:03 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.10.2 18.10 346.67 364.77 OK
r-devel-linux-x86_64-debian-gcc 1.10.2 11.17 161.12 172.29 ERROR
r-devel-linux-x86_64-fedora-clang 1.10.2 452.80 OK
r-devel-linux-x86_64-fedora-gcc 1.10.2 442.54 OK
r-devel-windows-x86_64 1.10.2 16.00 264.00 280.00 OK
r-patched-linux-x86_64 1.10.2 18.78 333.96 352.74 OK
r-release-linux-x86_64 1.10.2 15.62 337.31 352.93 OK
r-release-macos-arm64 1.10.2 169.00 OK
r-release-macos-x86_64 1.10.2 178.00 ERROR
r-release-windows-x86_64 1.10.2 19.00 263.00 282.00 OK
r-oldrel-macos-arm64 1.10.2 164.00 OK
r-oldrel-macos-x86_64 1.10.2 413.00 OK
r-oldrel-windows-x86_64 1.10.2 17.00 332.00 349.00 OK

Check Details

Version: 1.10.2
Check: package dependencies
Result: NOTE Packages suggested but not available for checking: 'bayesplot', 'brms', 'car', 'ggplot2', 'mediation', 'pbkrtest', 'lme4', 'lmerTest', 'testthat', 'tibble' Packages which this enhances but not available for checking: 'CARBayes', 'geepack', 'mice', 'rstanarm' Flavor: r-devel-linux-x86_64-debian-gcc

Version: 1.10.2
Check: examples
Result: ERROR Running examples in ‘emmeans-Ex.R’ failed The error most likely occurred in: > base::assign(".ptime", proc.time(), pos = "CheckExEnv") > ### Name: auto.noise > ### Title: Auto Pollution Filter Noise > ### Aliases: auto.noise > ### Keywords: datasets > > ### ** Examples > > # (Based on belief that noise/10 is in decibel units) > noise.lm <- lm(noise/10 ~ size * type * side, data = auto.noise) > > # Interaction plot of predictions > emmip(noise.lm, type ~ size | side) Error in .requireNS("ggplot2", "The 'ggplot' engine requires the 'ggplot2' package be installed.") : The 'ggplot' engine requires the 'ggplot2' package be installed. Calls: emmip -> emmip.default -> .requireNS -> fail Execution halted Flavor: r-devel-linux-x86_64-debian-gcc

Version: 1.10.2
Check: tests
Result: ERROR Running ‘testthat.R’ [0s/1s] Running the tests in ‘tests/testthat.R’ failed. Complete output: > library(testthat) Error in library(testthat) : there is no package called 'testthat' Execution halted Flavor: r-devel-linux-x86_64-debian-gcc

Version: 1.10.2
Check: re-building of vignette outputs
Result: ERROR Error(s) in re-building vignettes: ... --- re-building ‘AQuickStart.Rmd’ using rmarkdown --- finished re-building ‘AQuickStart.Rmd’ --- re-building ‘FAQs.Rmd’ using rmarkdown --- finished re-building ‘FAQs.Rmd’ --- re-building ‘basics.Rmd’ using rmarkdown Quitting from lines 260-262 [unnamed-chunk-13] (basics.Rmd) Error: processing vignette 'basics.Rmd' failed with diagnostics: The 'ggplot' engine requires the 'ggplot2' package be installed. --- failed re-building ‘basics.Rmd’ --- re-building ‘comparisons.Rmd’ using rmarkdown Quitting from lines 113-114 [unnamed-chunk-8] (comparisons.Rmd) Error: processing vignette 'comparisons.Rmd' failed with diagnostics: The 'ggplot' engine requires the 'ggplot2' package be installed. --- failed re-building ‘comparisons.Rmd’ --- re-building ‘confidence-intervals.Rmd’ using rmarkdown --- finished re-building ‘confidence-intervals.Rmd’ --- re-building ‘interactions.Rmd’ using rmarkdown Quitting from lines 76-77 [unnamed-chunk-4] (interactions.Rmd) Error: processing vignette 'interactions.Rmd' failed with diagnostics: The 'ggplot' engine requires the 'ggplot2' package be installed. --- failed re-building ‘interactions.Rmd’ --- re-building ‘messy-data.Rmd’ using rmarkdown Quitting from lines 56-58 [unnamed-chunk-2] (messy-data.Rmd) Error: processing vignette 'messy-data.Rmd' failed with diagnostics: there is no package called 'car' --- failed re-building ‘messy-data.Rmd’ --- re-building ‘models.Rmd’ using rmarkdown --- finished re-building ‘models.Rmd’ --- re-building ‘predictions.Rmd’ using rmarkdown Quitting from lines 82-87 [unnamed-chunk-3] (predictions.Rmd) Error: processing vignette 'predictions.Rmd' failed with diagnostics: could not find function "lmer" --- failed re-building ‘predictions.Rmd’ --- re-building ‘re-engineering-clds.rmd’ using rmarkdown --- finished re-building ‘re-engineering-clds.rmd’ --- re-building ‘sophisticated.Rmd’ using rmarkdown Quitting from lines 51-54 [unnamed-chunk-2] (sophisticated.Rmd) Error: processing vignette 'sophisticated.Rmd' failed with diagnostics: there is no package called 'lme4' --- failed re-building ‘sophisticated.Rmd’ --- re-building ‘transformations.Rmd’ using rmarkdown Quitting from lines 197-198 [unnamed-chunk-12] (transformations.Rmd) Error: processing vignette 'transformations.Rmd' failed with diagnostics: The 'ggplot' engine requires the 'ggplot2' package be installed. --- failed re-building ‘transformations.Rmd’ --- re-building ‘utilities.Rmd’ using rmarkdown --- finished re-building ‘utilities.Rmd’ --- re-building ‘vignette-topics.Rmd’ using rmarkdown [WARNING] Div at vignette-topics.knit.md line 10 column 1 unclosed at vignette-topics.knit.md line 793 column 1, closing implicitly. --- finished re-building ‘vignette-topics.Rmd’ --- re-building ‘xplanations.Rmd’ using rmarkdown Quitting from lines 200-205 [unnamed-chunk-2] (xplanations.Rmd) Error: processing vignette 'xplanations.Rmd' failed with diagnostics: The 'ggplot' engine requires the 'ggplot2' package be installed. --- failed re-building ‘xplanations.Rmd’ --- re-building ‘xtending.Rmd’ using rmarkdown --- finished re-building ‘xtending.Rmd’ SUMMARY: processing the following files failed: ‘basics.Rmd’ ‘comparisons.Rmd’ ‘interactions.Rmd’ ‘messy-data.Rmd’ ‘predictions.Rmd’ ‘sophisticated.Rmd’ ‘transformations.Rmd’ ‘xplanations.Rmd’ Error: Vignette re-building failed. Execution halted Flavor: r-devel-linux-x86_64-debian-gcc

Version: 1.10.2
Check: examples
Result: ERROR Running examples in ‘emmeans-Ex.R’ failed The error most likely occurred in: > ### Name: cld.emmGrid > ### Title: Compact letter displays > ### Aliases: cld.emmGrid cld.emm_list > > ### ** Examples > > if(requireNamespace("multcomp")) + emm_example("cld-multcomp") --- Running code from 'system.file("extexamples", "cld-multcomp.R", package = "emmeans")' > pigs.lm <- lm(log(conc) ~ source + factor(percent), + data = pigs) > pigs.emm <- emmeans(pigs.lm, "percent", type = "response") > multcomp::cld(pigs.emm, alpha = 0.1, Letters = LETTERS) Error in .requireNS("multcompView", "The 'multcompView' package must be installed to use CLD methods") : The 'multcompView' package must be installed to use CLD methods Calls: emm_example ... <Anonymous> -> cld.emmGrid -> .mcletters -> .requireNS -> fail Execution halted Flavor: r-release-macos-x86_64